设为首页加入收藏

微信关注
官方微信号:南方财富网
加关注获取每日精选资讯
搜公众号“南方财富网”即可,欢迎加入!
广告服务联系我们网站地图

通达信万能主图指标公式具体分析

南方财富网 www.kzdos.com 2017-12-18 15:33 股旁网

  AAF:=LLV(LOW,34),LINETHICK1,COLOR0000FF;

  BBF:=MA(AAF,4),LINETHICK1,COLORFF00FF;

  TYP := (HIGH + LOW + CLOSE)/3;

  CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));

  差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;

  CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));

  差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;

  CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));

  差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;

  CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));

  差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;

  CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));

  差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;

  CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;

  AAA:=(3*C+H+L+O)/6;

  VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)

  +4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

  VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;

  VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;

  VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;

  VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;

  VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

  短线:=VAR1,COLORWHITE;

  中线:=VAR6,COLORYELLOW;

  DRAWBAND(短线,RGB(255,255,50),中线,RGB(0,0,220));

  下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;

  TJ1:=CCI1》差值4;

  立桩量:=FILTER(TJ1,0),NODRAW;

  TJ2:=IF(BARSLAST(立桩量)=1 ,1,0);

  成立1:=TJ2=1;

  条件成立1:=FILTER(成立1,5);

  TJ11:= CCI1《-差值4 ;

  立桩量2:=FILTER(TJ11,0),NODRAW;

  TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE》REF(HIGH,1),1,

  IF(BARSLAST(立桩量2)=2 AND CLOSE》REF(HIGH,2),1,

  IF(BARSLAST(立桩量2)=3 AND CLOSE》REF(HIGH,3),1,0)));

  TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE》REF(LOW,1),1,0);

  成立2:=TJ=1;

  条件成立2:=FILTER(成立2,5);

  TJ111:=(ABS(CCI1)》CCI AND ABS( 差值1)》 ABS(差值5))

  OR (VOL=HHV(VOL,10) AND VOL》2*REF(VOL,1) AND CLOSE》VAR1);

  立桩量3:=FILTER(TJ111,5);

  TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE》REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE》REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE》REF(LOW,3),1,0)));

  成立:=TJ3=1;

  条件成立:=FILTER(成立,5);

  DRAWICON(条件成立 AND 下跌!= VAR6{ AND BB13》0},L*0.97,23);

  LC:=REF(CLOSE,1);

  RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

  FF:=EMA(CLOSE,3);

  MA15:=EMA(CLOSE,21);

  DRAWICON(CROSS(FF,MA15),LOW*0.97,23);

  DRAWTEXT(CROSS(88,RSI),(HIGH * 1.01),‘R背’),COLOR00FF00;

  X1:=(C+L+H)/3;

  BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

  EMA8:=EMA(C,8);

  DRAWTEXT(FILTER(BB13》1 AND EMA(X1,13)》REF(EMA(X1,8),1),10),

  EMA8,‘∠’),COLORWHITE;

  超买:MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;

  超卖:MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;

  上:=EMA(C,3),COLORBLUE,LINETHICK1;

  中:=EMA(C,5),COLORWHITE,LINETHICK1;

  下:=EMA(中,5),COLOR00FF00,LINETHICK1;

  QQ:= C《中;

  MM:=上》REF(上,1) AND REF(上,1)《REF(上,2) ;

  V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  V2:=(1-7/100)*(DMA(CLOSE,V1));

  V3:=(1+7/100)*(DMA(CLOSE,V1));

  V5:=MA((LOW+HIGH+CLOSE)/3,5);

  MA1:=MEMA(CLOSE,5);

  MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;

  MA3:=IF(MA2》0,MA2,MA2);

  MA5:=MA(CLOSE,5),COLOR888899;

  MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;

  VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)》=REF(C,2) OR REF(C,1)》=REF(C,3))

  OR REF(C,1)=HHV(C,4) AND CLOSE》=REF(C,2) OR REF(C,2)=HHV(C,4) AND

  REF(C,3)=LLV(C,4) AND C》=REF(C,1) OR REF(C,3)=HHV(C,4) AND

  C》=REF(C,1) AND C》=REF(C,2);

  {收盘价=4日内收盘价的最高值 AND 昨收》=2日前的收盘价}

  VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);

  {收盘价=4日内收盘价的最高值 AND 昨收=4日内收盘价的最低值}

  VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)《REF(C,2) OR REF(C,1)《REF(C,3)) OR

  REF(C,1)=LLV(C,4) AND C《REF(C,2) OR REF(C,2)=LLV(C,4) AND

  REF(C,1)=HHV(C,4) AND C《REF(C,1) OR REF(C,3)=LLV(C,4) AND

  C《REF(C,1) AND C《REF(C,2);

  {收盘价=4日内收盘价的最低值 AND (昨收《2日前的收盘价}

  VAR04:=REF(C,1)=LLV(C,4) AND C》=REF(C,2) OR REF(C,2)=LLV(C,4) AND

  REF(C,1)《=REF(C,3) AND REF(C,2)《REF(C,4) AND C》=REF(C,1);

  {昨收=4日内收盘价的最低值 AND 收盘价》=2日前的收盘价}

  VAR05:=REF(C,1)=HHV(C,4) AND C《REF(C,2) OR (REF(C,2)=HHV(C,4) AND

  REF(C,1)》REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)》REF(C,2)) AND

  REF(C,2)》=REF(C,4) AND C《REF(C,1);

  {昨收=4日内收盘价的最高值 AND 收盘价《2日前的收盘价}

  VAR06:=V5》REF(V5,1) AND REF(V5,1)《REF(V5,2);

  {今日V5向上形成拐点}

  VAR07:=LOW《HHV(V5,13) AND HIGH》HHV(V5,13) AND CLOSE》REF(C,1) AND CLOSE》OPEN;

  VAR08:=VAR07 AND COUNT(VAR06,2);

  VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);

  VAR10:=EMA(MA(C,13),13);

  VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09《0,2) AND

  CROSS(VAR09,MA(VAR09,2)))=1,5);

  VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09》50,2) AND

  CROSS(MA(VAR09,2),VAR09))=1,1);

  VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;

  VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);

  VAR15:=MA(C,18)》=REF(MA(C,18),3) AND CROSS(C,MA(C,18));

  VAR16:=VAR08 AND NOT(REF(VAR08,1));

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  金叉:=CROSS(J,D);

  死叉:=CROSS(D,J);

  买1:=(VAR14 OR VAR15) AND VAR11;

  买2:=(VAR14 OR VAR15) AND VAR4;

  买3:=(VAR14 OR VAR15) AND VAR2;

  买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);

  买5:=(金叉 AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);

  {涨停}

  STICKLINE(CLOSE》REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),

  COLOR00FFFF;

  {跌停}

  STICKLINE(CLOSE《REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),

  COLORGREEN;

  {蓝}

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,3.3,0),COLORFF6600;

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,2.4,0),COLORFF8800;

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,1.3,0),COLORFFAA00;

  STICKLINE(OPEN》=CLOSE,CLOSE,OPEN,0.6,0),COLORFFCC00;

  {红}

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,3.3,0),COLOR000099;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,2.4,0),COLOR0000BB;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,1.3,0),COLOR0000DD;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,0.5,0),COLOR0000FF;

  {绿}

  STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR009900;

  STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,2.4,0),COLOR00BB00;

  STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,1.3,0),COLOR00DD00;

  STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;

  {灰}

  STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR999999;

  STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;

  STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,1.3,0),COLORDDDDDD;

  STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;

  STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;

  STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000066;

  DRAWICON(VAR16,LOW-0.02,15);

  DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5 AND MM,LOW-0.05,23);

  DRAWICON(死叉 OR CROSS(50,VAR09) AND QQ AND K》50,HIGH+0.01,2);

  TTJ:=CROSS(FF,MA15);

  TTJ0:=VAR16;

  TTJ1:=买1 OR 买2 OR 买3 OR 买4 OR 买5 AND MM;

  XG0:=TTJ AND TTJ0;

  XG1:=TTJ AND TTJ1;

  XG:=XG0 OR XG1;

  DRAWTEXT(XG,LOW*0.93,‘全’),COLORRED;

  DRAWTEXT(XG,LOW*0.93-0.3,‘仓’),COLORRED;

  GET:ZIG(3,3),COLORYELLOW;

  PL5:=ZIG(3,5);

  EN1:=ZIG(3,5)》REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)《=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)《=REF(ZIG(3,5),3);

  EX1:=ZIG(3,5)《REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)》=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)》=REF(ZIG(3,5),3);

  PL10:=ZIG(3,10);

  EN2:=ZIG(3,10)》REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)《=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)《=REF(ZIG(3,10),3);

  EX2:=ZIG(3,10)《REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)》=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)》=REF(ZIG(3,10),3);

  PL20:=ZIG(3,20);

  EN3:=ZIG(3,20)》REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)《=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)《=REF(ZIG(3,20),3);

  EX3:=ZIG(3,20)《REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)》=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)》=REF(ZIG(3,20),3);

  PL40:=ZIG(3,40);

  走强1:=BARSLAST(PL5《REF(PL5,1));

  走弱1:=BARSLAST(PL5》REF(PL5,1));

  走强2:=BARSLAST(PL10《REF(PL10,1));

  走弱2:=BARSLAST(PL10》REF(PL10,1));

  走强3:=BARSLAST(PL20《REF(PL20,1));

  走弱3:=BARSLAST(PL20》REF(PL20,1));

  ZTJZ5:=IF(PL10》REF(PL10,1),COUNT(EN1,走强2),0);

  ZTJD5:=IF(PL10》REF(PL10,1),COUNT(EX1,走强2),0);

  DTJZ5:=IF(PL10《REF(PL10,1),COUNT(EN1,走弱2),0);

  DTJD5:=IF(PL10《REF(PL10,1),COUNT(EX1,走弱2),0);

  ZTJZ10:=IF(PL20》REF(PL20,1),COUNT(EN2,走强3),0);

  ZTJD10:=IF(PL20》REF(PL20,1),COUNT(EX2,走强3),0);

  DTJZ10:=IF(PL20《REF(PL20,1),COUNT(EN2,走弱3),0);

  DTJD10:=IF(PL20《REF(PL20,1),COUNT(EX2,走弱3),0);

  DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,‘(A)’),COLORFFFF00;

  DRAWTEXT(EX1 AND DTJD5=2,H*1.02,‘(B)’),COLORFF00FF;

  DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,‘(C)’),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJD5=1,H*1.02,‘⑴’),COLOR0000FF;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=2,L*0.98,‘⑵’),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJZ5=2,H*1.02,‘⑶’),COLOR0000FF;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=3,L*0.98,‘⑷’),COLOR0000FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.02,‘⑸’),COLOR0000FF;

  DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,‘Ⅰ’),COLORFF00FF;

  DRAWTEXT(EX2 AND DTJD10=2,H*1.05,‘Ⅱ’),COLORFFFF00;

  DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,‘Ⅲ’),COLOR0000FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.03,‘①’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=2,L*0.95,‘②’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)

  AND EX2,H*1.03,‘③’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=3,L*0.95,‘④’),LINETHICK3,COLOR00FFFF;

通达信万能主图指标公式
  南方财富网微信号:南方财富网

547351787 610350350 399349573 58534823 133347885 984346619 716345640 596344294 184343660 19342391 594341300 985340150 484339164 827338912 286337723 377336735 940335654 543334303 557333376 542332920 108331847 195330651 99432917 451328572 87232714 183326718 879325323 823324642 106323983 300322934 552321343 5183209 889319550 692318189 369317109 776316358 970315291 575314591 492313646 118312684 24931148 410310144 647309598 659308511 985307722 914306365 364305814 432304527 688303257 26302857 876301984 572300115 519299246 139298589 751297281 831296571 58295745 220294328 4293336 257292536 776291542 508290958 400289429 236288686 885287349 91328622 513285937 56628430 679283971 87282235 285281945 784280156 221279500 498278987 440277179 376276108 963275979 797274208 836273797 187272992 386271126 786270234 754269649 158268910 622267651 396266898 909265872 881264108 955263905 856262792 995261183 702260901 881259378 557258481 931257237 673256583 382255503 840254817 788253988 951252132
友情链接:华夏玻璃网 | 请看小说网 | TXT电子书免费下载 | 飞丸网 | 金软网络 | 绍兴月嫂网 | 娱乐新闻 | 请看小说网 | 信茂文学 | 重庆小故事 | 红橙紫化工网 | 绍兴月嫂网 | 钱龙 | 跳波比 | 大家网 | 马鞍山作文网 | 一点点说封建 | 雨花素材大全 | 浩宇小说 | 钱龙 | 石家庄传媒网 | 佛山在线 | 029作文网 | 新瑞利邦 | 信茂文学 | 柒彩网 | 金软网络 | 太子妃创作室 | 浩宇小说 | 米国中文网 | 飞丸网 | 联商网 | 优游网 | 马鞍山作文网 | ROM之家官网 | 大家网 | 中华资源库 | 怀化作文网 | 奥氏网 | 红橙紫化工网 | 耀陆纺织网 | 雨花素材大全 | 三文天小说网 | 跳波比 | 科技紫微星座网 | 重庆小故事 | 发展都市网 | 一点点说封建 | 爱酷糖 |